Announcement

Announcement Module
Collapse
No announcement yet.

How to turn off heading/title capitalization

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to turn off heading/title capitalization

    Hi,

    My question is according to the title.
    For e.g: "The Best Online Documentation"
    I want to have it "The best online documentation"

    Also is it possible to put a black border or box behind the the title to make it more visible? Sometimes it can be difficult to see what written especially with light coloured image bg.


    Thanks

  • #2
    Please wait for our new version, more header controls are going to add that has option to transform text to upper or lower or none and much more.
    Best Regards,

    Jabin Kadel
    Founder & CEO
    WpSmartApps.com

    Comment


    • #3
      I was having similar issues as ahkam. I see that there are several places to control capitalization rules now, including the header title, breadcrumbs, and documentation categories.

      Thank you for providing the option to turn this "feature" off. However, I would suggest a few things:

      - Do NOT have it turned on by default. It is unexpected behavior and frustrating to change (there are multiple places the settings have to be changed to turn it off, once you realize that you can).
      - Make it grammatically correct. The "Capitalize" option capitalizes every word in the title, which is often not desired: e.g. "Director of First Impressions." Refer to http://titlecapitalization.com/ for proper title capitalization rules.
      - Provide a setting to disable it globally. This would save me the headache of changing it initially, plus for every documentation category I create.

      One more thing:

      Even though I've set the documentation category names to not be capitalized, they are still capitalized on the category list page (on your demo site, that would be this page: http://demo.wpsmartapps.com/themes/m...ocumentations/). Is there another place I need to change a setting to fix that issue?

      Comment


      • #4
        Hi Andy,

        Thanks for the list of suggestion. Because of theme layout we have added capitalize by default at the first place, but we will re-think about this default mode and try to change it accordingly. About changing category for the home page please add below CSS code on the custom code section (manual options -> custom code)

        HTML Code:
        .news-list h2 a {
            text-transform: none;
        }
        Best Regards,

        Jabin Kadel
        Founder & CEO
        WpSmartApps.com

        Comment


        • #5
          That fixed it. Thanks!

          Comment


          • #6
            The new version 1.7 has this issue fixed you can also upgrade to our new version.
            Best Regards,

            Jabin Kadel
            Founder & CEO
            WpSmartApps.com

            Comment


            • #7
              Hi,

              Many thanks for the prompt updates!

              I have updated it to 1.7.1.
              The "documentation categories" contain the option to turn of capitalization, but that is only implemented in the categories.
              The rest of the "documenations" that are added under a category are still capitalized.

              Also, is there going to be a global control, so we can turn on and off capitalization on the whole site?

              Thanks

              Comment


              • #8
                Sure we will add global control to turn on and off capitalization, Please wait for the new version.
                Best Regards,

                Jabin Kadel
                Founder & CEO
                WpSmartApps.com

                Comment


                • #9
                  Hi again,

                  I have updated to 1.8 and i have noticed the global settings, but they are not changing the titels in documents added to "documentation".
                  Note that the category name will change, but not the items that are added under these categories


                  I am talking about this:
                  <div class="doc-single-post" id="single-post-container">
                  <div class="page-title-header">
                  <h2 class="manual-title title singlepg-font"> 1.1 Titel without capitalization</h2>
                  <p style="min-height:10px;" >
                  Last edited by ahkam; 11-01-2016, 01:21 PM.

                  Comment


                  • #10
                    We will look at this issue and solve it on our new upcoming version which going to available soon.
                    Best Regards,

                    Jabin Kadel
                    Founder & CEO
                    WpSmartApps.com

                    Comment


                    • #11
                      Hello Jabin,
                      I have the similar situation. All titels getting capitalized. I can not find the option to disable it. I also tried to add the CSS code
                      .news-list h2 a { text-transform: none; } but it didn't work for me.

                      The titels I'm speaking about:

                      news: http://support.smartwop.de/news/
                      popular articles in the knowledge base section: http://support.smartwop.de/knowledge...mhintergrunds/
                      documentation titles: http://support.smartwop.de/documenta...er-den-export/

                      Could you kindly help me fix this?

                      Comment


                      • #12
                        Found a solution. Just used find a replace "capitalize" to "none" in styles.css

                        Comment


                        • #13
                          Thanks for the update
                          Best Regards,

                          Jabin Kadel
                          Founder & CEO
                          WpSmartApps.com

                          Comment

                          Working...
                          X